8455澳门新_8455新葡萄娱乐【官网】

那就升级版本吧,终端也无法登录

    前段时间遇到开发人员更新glibc版本,把/usr/lib64/libc-2.12.so & libc.so.6 -> libc-2.12.so 这个软连接更改之后导致报错:

CentOS 6.x误删libc.so.6,导致重启Kernel panic - not syncing: Attempted to kill init!报错问题

CentOS 6.x x64 如果失误删除系统/lib64/libc.so.6软连接文件,会导致无法执行系统命令,无法新建ssh或者直接登录系统终端。

重启系统后会提示:

Kernel panic - not syncing: Attempted to kill init!

无法正常启动进入系统。

8455澳门新 1

安装nginx时候出现版本太低的问题:

场景需求

默认的Centos6.5 glibc版本最高为2.12, 而在进行Nodejs开发时项目所依赖的包往往需要更高版本的glibc库支持, 因此在不升级系统的前提下, 需要主动更新系统glibc库. 一般遇到错误libc.so.6: version GLIBC_2.14 not found时表示需要对glibc进行升级了.

glibc版本

查看系统glibc库版本可使用如下命令:

$ strings/lib64/libc.so.6|grep GLIBC_

Centos6.5输出如下glibc版本列表, 从此图可以看出系统最高支持glibc的2.12版本:

8455澳门新 2

另外, 执行$ ll /lib64/libc**可以看到此时的libc.so.6是libc-2.12.so的别名, 如下图所示:

8455澳门新 3

glibc安装

首先, 点击此处下载glibc点击下载, 得到glibc-2.14.tar.gz使用如下命令解压glibc-2.14.tar.gz:

$ tar-xzvf glibc-2.14.tar.gz

当前目录下得到目录glibc-2.14, 执行$cd glibc-2.14命令进入目录, 依次执行如下命令编译安装glibc-2.14:

$ mkdir build// 在glibc-2.14目录下建立build文件夹

$ cd build// 进入build目录

$../configure--prefix=/opt/glibc-2.14// 配置glibc并设置当前glibc-2.14安装目录

$ make&&make install// 编译安装glibc-2.14库

glibc软链

安装完成后, 建立软链指向glibc-2.14, 执行如下命令:

$ ln-sf/opt/glibc-2.14/lib/libc-2.14.so/lib64/libc.so.6

****本处并未删除先前的libc.so.6软链,而是选择直接覆盖,因为直接删除libc.so.6可能会导致系统运行异常以及无法启动

注意

删除libc.so.6之后可能导致系统命令不可用的情况, 可使用如下方法解决:

$ LD_PRELOAD=/opt/glibc-2.14/lib/libc-2.14.so ln-s/opt/glibc-2.14/lib/libc-2.14.so/lib64/libc.so.6

如果上述更新失败可使用如下命令还原:

$ LD_PRELOAD=/lib64/libc-2.12.so ln-s/lib64/libc-2.12.so/lib64/libc.so.6// libc-2.12.so 此项是系统升级前的版本

执行成功之后可执行strings/lib64/libc.so.6|grep GLIBC_ 命令 和ll /lib64/libc** 查看当前的GLIBC支持的版本和libc.so.6软链的对应情况

glibc升级引起locale警告

解决:设置语言相关的locale-archive文件

8455澳门新 4

###复制到编译好的glibc 2.14的lib/locale中,记得先创建locale目录

# mkdir /opt/glibc-2.14/lib/locale

# cp /usr/lib/locale/locale-archive /opt/glibc-2.14/lib/locale/

# /usr/local/glibc-2.14/bin/localedef -i en_US -f UTF-8 en_US.UTF-8 ##运行生成相应的locale配置文件

     ls: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

解决办法:

  /lib64/libc.so.6: version `GLIBC_2.14' not found

    无法远程登录,终端也无法登录,也无法单用户登录,如图:

情况一:

如果还连着的ssh终端,没有断开,直接执行如下命令即可恢复:

# LD_PRELOAD=/lib64/libc-2.12.so ln -s /lib64/libc-2.12.so /lib64/libc.so.6

好吧,人家需要的是'GLIBC_2.14',先查看一下当前系统glibc的情况:

8455澳门新 5

情况二:

ssh已经断开,无法新建新的ssh连接,重启系统,报错无法进入系统。

出现报错:Kernel panic - not syncing: Attempted to kill init!

处理办法

插入系统光盘,进入rescue救援模式,将链接文件复制到被删除的文件系统。

操作步骤如下:

1、开机进入BIOS设置,修改BOOT启动顺序为光盘优先启动 CD-ROM Drive;

2、重启系统后由光盘引导,进入安装启动菜单,选择“Rescue install system”救援模式;

8455澳门新 6

3、选择语言,保持默认English

8455澳门新 7

4、选择键盘类型,保持默认us

8455澳门新 8

5、是否启动网络,需要根据你实际情况进行选择,如果需要通过联网拷贝数据,选择YES,在这里我们选择NO;

8455澳门新 9

6、进入到Rescue界面,选择Continue

8455澳门新 10

7、系统挂载在/mnt/sysimage下 ,选择OK

(如果要到root环境下,运行 chroot /mnt/sysimage 命令,此处不需要)

8455澳门新 11

8455澳门新 12

8、选择进入模式:shell 进入命令行模式,fakd是诊断模式,reboot重启电脑,这里选择shell

8455澳门新 13

9、进入shell命令行,提示符为

bash-4.1#

8455澳门新 14

10、不要执行chroot /mnt/sysimage,因为硬盘文件系统就在该目录下,从/lib64下复制软连接即可,操作如下:

bash-4.1# cd /lib64

bash-4.1# cp -d libc.so.6 /mnt/sysimage/lib64/libc.so.6

bash-4.1#8455澳门新, reboot

之后即可恢复正常

8455澳门新 15

strings /lib64/libc.so.6 |grep GLIBC

终端登录:

8455澳门新 16

8455澳门新 17

glibc版本.png

单用户:

好吧确实比较低,那就升级版本吧!
先是考虑yum update glibc直接升级,失败

8455澳门新 18

然后到http://ftp.gnu.org/gnu/glibc/glibc-2.14.tar.xz
tar glibc-2.14.tar.gz
cd glibc-2.14
mkdir build
cd build
../configure --prefix=/usr/local/glibc-2.14
make -j4 (时间稍长,请耐心等待)
make install

其实在执行误操作之后只要不断开远程连接还有挽回的余地,但远程异常断开连接之后很多人就没有辙了,准备抢救数据&文件,重装系统,其实这里咱们先不要着急重装系统,咱们来试试rescue !

看看现在libc.so.6在哪个位置,然后修改软链接
ln -s /usr/local/glibc-2.14/lib/libc-2.14.so /lib64/libc.so.6
创建链接时出了问题,无法创建,说是已存在
然后我就手欠把libc.so.6删了!
rm libc.so.6
然后就傻逼了,各种命令都不能用了,报错信息
/bin/ls: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
网上找方法
先删除连接 :
第一步
cd /lib64
第二步
LD_PRELOAD=/lib64/libc-2.3.6.so rm libc.so.6 -->我可以正常删除,这一步省略,不能正常删除的,先执行该步,**libc-2.3.6.so文件与当前服务器文件保持一致
建立新连接 :
LD_PRELOAD=/usr/local/glibc-2.14/lib/libc-2.14.so ln -s /usr/local/glibc-2.14/lib/libc-2.14.so libc.so.6

一、首先准备好系统安装盘,使用安装盘启动:

strings /lib64/libc.so.6 |grep GLIBC

本文由8455澳门新发布于新闻资讯,转载请注明出处:那就升级版本吧,终端也无法登录

相关阅读